SQL Server – в основном устаревший


Обзор экземпляров SQL Server показал, что более чем на половине из них не установлен последний пакет обновления, а еще большая часть работает с версиями SQL Server, которые больше не поддерживаются.

Опрос был инициирован Полом Рэндалом, генеральным директором SQLskills.com и опубликован в его блоге. Он собрал результаты для 3085 экземпляров SQL Server от нескольких сотен респондентов, а затем проанализировал результаты, чтобы определить, какому номеру выпуска и версиям соответствуют номера сборки. Его шокирующие откровения:

51% всех экземпляров в опросе устарели, по крайней мере, из-за того, что они не используют последнюю сборку SP, а 53% всех экземпляров в опросе не поддерживаются.

Статистика, основанная на 3085 экземплярах опроса SQL, сведена в эту таблицу:

Менее 6% респондентов используют SQL Server 2102, и даже у четверти из них не установлен последний пакет обновления. Это вызывает множество вопросов. Рэндал полагает, что есть причины, по которым компании остаются со старыми неподдерживаемыми версиями SQL Server, в частности, когда они запускают сторонние приложения, не сертифицированные для новых версий. Однако отказ от установки пакета обновления оставляет сервер уязвимым для атак из-за известных слабых мест.

Интересно, но, возможно, неудивительно, что 41 процент экземпляров все еще работает на SQL Server 2005; скачок производительности с 2000 до 2005 был существенным, но последующий прирост производительности с 2008, 2008 R2 и даже 2012 не так впечатляет, и если вы не используете новые функции, многие администраторы и разработчики будут думать вместе строки «если не сломано, не чинить». Однако, учитывая тот факт, что поддержка 2005 года закончилась, а поддержка 2008 и 2008 R2 находится в процессе завершения, это означает, что более 50 процентов установок работают без поддержки со стороны Microsoft.

Как говорит Пол Рэндал, хотя есть много причин, чтобы по-прежнему использовать более старую версию SQL Server, по крайней мере, используйте последний пакет обновления или накопительное обновление, если это возможно!


Добавить комментарий