Выпущены JQuery 1.11 и 2.1

Команда jQuery только что выпустила новые версии обеих веток jQuery. Хотя они содержат исправления ошибок и поддержку большего количества веб-сред, API-интерфейсы не претерпевают никаких изменений.

Эта последняя версия совместима с бета-версией, о которой мы сообщали в сентябре 2013 года, поэтому код должен работать быстрее, не требуя от разработчиков вносить изменения в свой существующий код.

С момента выпуска jQuery 2.0 было две версии jQuery. Те, что находятся в ветви 2.x, меньше и быстрее, но не поддерживают старые браузеры – в частности, они не поддерживают Internet Explorer до IE9, в то время как ветка 1.xx продолжает работать с IE6, 7 и 8. Теперь с версией 2.1. 0, ветвь 2.x добавляет поддержку нетрадиционных веб-сред, таких как node.js и плагины браузера для Chrome и Firefox.

Объявляя о выпусках в блоге jQuery, Дэйв Метвин говорит: «Мы исправили довольно много ошибок, но другие функции и изменения в основном организационные, которые не влияют на поведение API. Ваш код не должен ломаться, он должен работать немного быстрее ».

Он также напоминает разработчикам, что jQuery претерпел серьезные изменения в версии 1.9 и что есть плагин jQuery Migrate, который поможет тем, кто обновляется с более ранних версий.

Среди изменений предыдущих выпусков (в отличие от бета-версии) в новых версиях меньше принудительных макетов. Дэйв Метвин объясняет:

«В этом выпуске мы объявили войну тем местам, где мы могли непреднамеренно заставить браузер делать трудоемкий макет. Мы нашли несколько и устранили одну, в частности, которая могла возникнуть при изменении имен классов. Это может привести к значительному увеличению производительности некоторых страниц ».

Если вы пишете приложение с ограниченным пространством, теперь вы можете использовать детализированные пользовательские сборки, выбирая определенные небольшие подмножества библиотеки. Вы можете узнать больше в файле Readme jQuery на GitHub.

В новых версиях также меньше накладных расходов при запуске. Команда переработала функции обнаружения, чтобы они запускались при первой необходимости. Если вы никогда не вызываете API, требующий обнаружения этой функции, вы никогда не запускаете этот код. Это должно быть особенно полезно на мобильных платформах.

Новые версии публикуются на npm и Bower. Публикация npm означает, что вы можете использовать их с node или browserify, хотя для работы в node поддерживается только ветка 2.x.

Один элемент, который вы не найдете в этом выпуске, – это комментарий исходной карты в уменьшенном файле. Команда говорит, что исходные карты оказались очень проблематичной и загадочной вещью для разработчиков. Исходные карты по-прежнему будут создаваться и распространяться, но если вы хотите их увидеть, вам нужно будет добавить соответствующий комментарий исходной карты в конце минифицированного файла. В сообщении блога говорится, что команда надеется вернуть и улучшить поддержку исходных карт в будущем.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *