HHVM 3.25 По Умолчанию PHP7


Разработчики из Facebook выпустили новую версию HHVM, виртуальной машины хип – хопа. Поддержка PHP в новой версии была изменена на PHP 7 по умолчанию, а не на PHP 5 предыдущей версии.

HHVM-это виртуальная машина с открытым исходным кодом, предназначенная для выполнения программ, написанных на Hack и PHP.  Он был разработан в Facebook, чтобы обеспечить способ преобразования PHP-скрипта в C++, чтобы его можно было скомпилировать и запустить на веб-серверах. HHVM поддерживает Hack и PHP 7. PHP 5 по-прежнему доступен, но не поддерживается. HHVM использует компиляцию JIT (JIT), чтобы сочетать хорошую производительность с гибкой средой разработки. 

Hack-это язык программирования, разработанный Facebook для HHVM. Он предназначен для объединения быстрого цикла разработки динамически типизированного языка с дисциплиной, обеспечиваемой статической типизацией. Он делает это, предлагая “мгновенную проверку типа”. Это достигается путем постепенной проверки ваших файлов по мере их редактирования. Проверка обычно выполняется менее чем за 200 миллисекунд, поэтому это приемлемые накладные расходы. Facebook переместил всю свою кодовую базу на Hack, и есть версия с открытым исходным кодом в комплекте с HHVM.

Поддержка PHP 7 в новой версии выходит за рамки того, что она используется по умолчанию, с более широкой поддержкой функций PHP 7. Модификаторы видимости констант больше не вызывают ошибки синтаксического анализа, хотя они по-прежнему игнорируются. Еще несколько видов выражений теперь разрешены как вызываемые. Выражения уже были поняты средством проверки типов взлома, но не поддерживались средой выполнения. Еще одним улучшением совместимости PHP 7 является поддержка иерархии выбрасываемых, ошибок и исключений PHP7, в том числе в режиме Hack и в режиме PHP5.

Помимо PHP 7, была добавлена поддержка протокола адаптера отладки кода Visual Studio в дополнение к hphpd и XDebug. Протокол VS теперь является рекомендуемым интерфейсом отладки. Еще одно улучшение устраняет проблему безопасности CVE, которая потенциально может привести к отказу в обслуживании из-за обработки Proxygen недопустимых параметров HTTP2, что может привести к непропорциональному расходованию ресурсов сервером. В других местах параметры функции Hack inout теперь поддерживаются, и для взлома был сделан ряд других улучшений. 


Добавить комментарий